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Connection to EPM Add-in Fails With Error: "Failed to allocate a managed memory buffer"

Symptom:

- When users try to connect to a specific model they get an error "Failed to allocate a managed memory buffer of <some number> bytes

AND there are no errors or dumps on the server No ST22 dump
AND no errors in SLG1 or SM21
AND this happens to all users
AND EPM Add-in log shows the following error: |ERROR|BPC10Connection|FPMXLClient.Connection.RESTConnection.LoadMetaData||||||1|Failed to allocate a managed memory buffer of <some number> bytes. The amount of available memory may be low

 


Cause:

This error is generated when a certain threshold is reached during the connection process.


Resolution:

To resolve the issue follow the steps below to enable GZIP compression for REST service on the service side.

1. Run transaction SICFNavigate to default_host->sap->EPM_BPCDouble 
2. click on "REST"
3. On the next page, set compression to 'YES'


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